Skip to content

TRYTON software

Uwaga

Some software in the list below may require an additional licence and may not be generally available to all PLGrid users.

modulefiles

Versions:

Module Default
module load use.own
module load null
module load modules
module load module-info
module load module-git
module load dot

abinit

Versions:

Module Default
module load abinit/6.12.3

aero-h

Versions:

Module Default
module load aero-h/0.1

aero-t

Versions:

Module Default
module load aero-t/0.1

aku-h

Versions:

Module Default
module load aku-h/0.1

amber

Versions:

Module Default
module load plgrid/apps/amber/16-ib
module load amber/16-ib
module load amber/14-ib

autodock

Versions:

Module Default
module load plgrid/apps/autodock/4.2.3
module load autodock/4.2.5
module load autodock/4.2.3

binutils

Versions:

Module Default
module load plgrid/tools/binutils/2.40
module load binutils/2.40
module load binutils/2.35

blender

Versions:

Module Default
module load plgrid/apps/blender/2.62
module load plgrid/apps/blender/2.49b
module load blender/2.63a
module load blender/2.62
module load blender/2.49b

boost

Versions:

Module Default
module load plgrid/libs/boost/1.57.0-gcc4.8.1
module load boost/1.57.0-gcc4.8.1
module load boost/1.51.0-gcc4.5.3

cfour

Versions:

Module Default
module load cfour/rc

cgal

Versions:

Module Default
module load plgrid/libs/cgal/4.5.2
module load plgrid/libs/cgal/4.0.2
module load plgrid/libs/cgal/3.9-intel
module load cgal/4.5.2
module load cgal/4.2
module load cgal/4.0.2
module load cgal/3.9-intel

clustal-omega

Versions:

Module Default
module load clustal-omega/1.1.0

cmake

Versions:

Module Default
module load plgrid/tools/cmake/3.17.3
module load cmake/3.17.3
module load cmake/2.8.2

cp2k

Versions:

Module Default
module load cp2k/2.4

dalton

Versions:

Module Default
module load dalton/2.0

ebaltic

Versions:

Module Default
module load ebaltic/1.0

espresso

Versions:

Module Default
module load plgrid/apps/espresso/7.0
module load plgrid/apps/espresso/6.6
module load plgrid/apps/espresso/6.4.1
module load espresso/7.0
module load espresso/6.6
module load espresso/6.4.1
module load espresso/5.0.3

ferret

Versions:

Module Default
module load plgrid/apps/ferret/7.5.0
module load ferret/7.5.0
module load ferret/6.9.3

fluent

Versions:

Module Default
module load plgrid/apps/fluent/20.2.0
module load plgrid/apps/fluent/16.2
module load plgrid/apps/fluent/15.0
module load plgrid/apps/fluent/14.5.7
module load plgrid/apps/fluent/14.0.0
module load fluent/20.2.0
module load fluent/18.0
module load fluent/16.2
module load fluent/15.0
module load fluent/14.5.7
module load fluent/14.0.0

gamess

Versions:

Module Default
module load plgrid/apps/gamess/2017r1-mpi
module load plgrid/apps/gamess/2012.R1
module load plgrid/apps/gamess/2009.R3
module load gamess/2017r1-mpi
module load gamess/2012.R2-mpi
module load gamess/2012.R1
module load gamess/2009.R3

gaussian

Versions:

Module Default
module load plgrid/apps/gaussian/g09.D.01
module load plgrid/apps/gaussian/g09.C.01
module load gaussian/g16.B.01
module load gaussian/g09.D.01
module load gaussian/g09.C.01

gcc

Versions:

Module Default
module load plgrid/tools/gcc/7.3.0
module load plgrid/tools/gcc/4.5.3
module load plgrid/tools/gcc/10.2.0
module load plgrid/tools/gcc/10.1.0
module load gcc/7.3.0
module load gcc/4.8.1
module load gcc/4.5.3
module load gcc/10.2.0
module load gcc/10.1.0

git

Versions:

Module Default
module load git/2.18

glibc

Versions:

Module Default
module load plgrid/libs/glibc/2.14
module load glibc/2.18
module load glibc/2.14

gromacs

Versions:

Module Default
module load plgrid/apps/gromacs/4.5.3-mpi-d
module load plgrid/apps/gromacs/4.5.1
module load plgrid/apps/gromacs/2020.3
module load gromacs/4.5.3-mpi-s
module load gromacs/4.5.3-mpi-d
module load gromacs/4.5.1
module load gromacs/2020.3

hdf5

Versions:

Module Default
module load plgrid/libs/hdf5/1.8.17-intel
module load hdf5/1.8.17-intel
module load hdf5/1.8.11

htslib

Versions:

Module Default
module load htslib/1.4

impi

Versions:

Module Default
module load plgrid/tools/impi/5.0.3.048
module load plgrid/tools/impi/2019.5
module load plgrid/tools/impi/2017.1.132
module load impi/5.0.3.048
module load impi/4.0.3.008
module load impi/2019.5
module load impi/2017.1.132

intel

Versions:

Module Default
module load plgrid/tools/intel/2019.5-3
module load plgrid/tools/intel/2019.5-2
module load plgrid/tools/intel/2019.5
module load plgrid/tools/intel/17.1
module load plgrid/tools/intel/15.1
module load intel/2019.5-3
module load intel/2019.5-2
module load intel/2019.5
module load intel/17.1
module load intel/15.1
module load intel/12.1

irods

Versions:

Module Default
module load plgrid/tools/irods/4.2.2
module load plgrid/tools/irods/4.1.3
module load irods/4.2.2
module load irods/4.1.3
module load irods/4.0.3

jags

Versions:

Module Default
module load plgrid/tools/jags/4.2.0
module load plgrid/tools/jags/3.3.0
module load jags/4.2.0
module load jags/3.4.0
module load jags/3.3.0

java6

Versions:

Module Default
module load java6/1.6.0_45

java7

Versions:

Module Default
module load java7/1.7.0_21

java8

Versions:

Module Default
module load java8/1.8.0_11

julia

Versions:

Module Default
module load julia/0.6.0

kepler

Versions:

Module Default
module load plgrid/apps/kepler/2.3
module load kepler/2.4
module load kepler/2.3

lammps

Versions:

Module Default
module load plgrid/apps/lammps/4Jul12
module load lammps/4Jul12
module load lammps/10Aug15

mapyhalasu

Versions:

Module Default
module load plgrid/apps/mapyhalasu/0.1
module load mapyhalasu/0.2
module load mapyhalasu/0.1

marc

Versions:

Module Default
module load marc/2012

mkl

Versions:

Module Default
module load plgrid/libs/mkl/2019.5
module load plgrid/libs/mkl/2017.0.1
module load plgrid/libs/mkl/11.2.3
module load plgrid/libs/mkl/10.3
module load mkl/2019.5
module load mkl/2017.0.1
module load mkl/11.2.3
module load mkl/11.1
module load mkl/10.3

mpich

Versions:

Module Default
module load mpich/3.3.1

msc_nastran

Versions:

Module Default
module load msc_nastran/2013

namd

Versions:

Module Default
module load plgrid/apps/namd/2.9-ibverbs-smp
module load plgrid/apps/namd/2.11-ibverbs
module load namd/2.9-ibverbs-smp
module load namd/2.9-ibverbs
module load namd/2.11-ibverbs

nanomd

Versions:

Module Default
module load nanomd/2.2

nco

Versions:

Module Default
module load nco/4.7.5

numeca

Versions:

Module Default
module load numeca/8.10

acoustics

Versions:

Module Default
module load plgrid/apps/numeca/acoustics/5.2-2
module load numeca/acoustics/5.2-2

fine_open

Versions:

Module Default
module load plgrid/apps/numeca/fine_open/7.2
module load plgrid/apps/numeca/fine_open/6.2
module load numeca/fine_open/7.2
module load numeca/fine_open/6.2

fine_turbo

Versions:

Module Default
module load plgrid/apps/numeca/fine_turbo/12.1
module load numeca/fine_turbo/12.1

turbo

Versions:

Module Default
module load plgrid/apps/numeca/turbo/9.0-3
module load numeca/turbo/9.0-3

nwchem

Versions:

Module Default
module load nwchem/6.1.1

octave

Versions:

Module Default
module load plgrid/tools/octave/5.1.0
module load octave/5.1.0
module load octave/4.4.1

onedata

Versions:

Module Default
module load onedata/20.02.3.24

opencv

Versions:

Module Default
module load opencv/2.4.2-gcc453

openmpi

Versions:

Module Default
module load plgrid/tools/openmpi/2.0.2-intel-17.1-ib
module load plgrid/tools/openmpi/1.8.8-intel-15.1-ib
module load plgrid/tools/openmpi/1.6.0-gnu-4.5.3-ib
module load plgrid/tools/openmpi/1.4.5-intel-12.1.0-ib
module load plgrid/tools/openmpi/1.4.5-gcc-4.1.2-ib
module load openmpi/2.0.2-intel-17.1-ib
module load openmpi/1.8.8-intel-15.1-ib
module load openmpi/1.6.5-gnu-4.8.1-ib
module load openmpi/1.6.0-gnu-4.5.3-ib
module load openmpi/1.4.5-intel-12.1.0-ib
module load openmpi/1.4.5-gcc-4.1.2-ib

openmx

Versions:

Module Default
module load openmx/3.8.1-intel17.1

openssl

Versions:

Module Default
module load openssl/1.1.1g

pilgrim

Versions:

Module Default
module load pilgrim/1.0

platypus

Versions:

Module Default
module load platypus/0.8.1

r

Versions:

Module Default
module load r/3.1.2
module load r/3.1.0
module load r/3.0.2
module load r/3.0.0
module load plgrid/apps/r/3.1.0
module load plgrid/apps/r/3.0.2
module load plgrid/apps/r/3.0.0

siesta

Versions:

Module Default
module load siesta/trunk-462-mkl
module load siesta/4.1-b4-mkl
module load siesta/4.0.2-mkl
module load siesta/4.0.1-mkl
module load siesta/4.0-mkl
module load siesta/3.2-mkl
module load plgrid/apps/siesta/trunk-462-mkl
module load plgrid/apps/siesta/4.1-b4-mkl
module load plgrid/apps/siesta/4.0.1-mkl
module load plgrid/apps/siesta/4.0-mkl
module load plgrid/apps/siesta/3.2-mkl

360

Versions:

Module Default
module load tecplot/360/2017r2
module load tecplot/360/2013r2
module load plgrid/apps/tecplot/360/2017r2

vasp

Versions:

Module Default
module load vasp/5.4.4-mkl
module load vasp/5.4.4-impi-2019.5
module load plgrid/apps/vasp/5.4.4-impi-2019.5

python

Versions:

Module Default
module load python/3.8.5
module load python/3.11.4
module load python/2.7.9
module load python/2.6.9
module load python/2.6.4
module load plgrid/tools/python/3.8.5
module load plgrid/tools/python/3.11.4
module load plgrid/tools/python/2.6.9
module load plgrid/tools/python/2.6.4

protobuf

Versions:

Module Default
module load protobuf/2.4.1

ruby

Versions:

Module Default
module load ruby/2.0.0-p0

sluch

Versions:

Module Default
module load sluch/0.1

voro++

Versions:

Module Default
module load voro++/0.4.6

Last update: January 29, 2024